Knowledge Base support case for AllWebMenus, abstracted and stripped of all user’s private info.


Initial Email From:
Rick
Initial Email Subject: No Menu in IE9
Support Case Month: October 2012

Hallo Support

My menu shows in all browsers except in IE9

My setup is Latest Allwebmenus 5.3 Build #898 Joomla 2.5 and AllwebMenu's extension running of wamp local host.

All browser are up to date.
Firefox 15, Opera, Safari

I have uninstalled and re installed the joomla plugin a few times, recompiled the joomla zip also a few times but nothing.

I also use Template creator CK plugin for Joomla. Menu position is relative to element custom ID nav.

Its only IE9 that it wont show.

Help will be much appreciated here. And thanks for a grate program.

Regards

Rick

Reply From: Likno Customer Support

Dear Rick,

I am afraid I cannot be sure on what the problem is without actually seeing your page.

However my guess is that you are positioning your menu relative to an element and that you somehow ended up with duplicate IDs in your page. When this happens most browsers will just use the first element found, but IE will disregard all of them hence not showing the menu at all. Please check if your Positioning ID is duplicated in your page and remove any “extras” in order to fix the problem.

If this is not the problem, then please send me the URL so that I can check the page.

Regards,
Kostas
Likno Customer Support
www.likno.com
Create any type of javascript menu (CSS menu, drop-down menu, sliding menu), button, html tree, modal window, tooltip, accordion, tab, scroller, jQuery slider or design for your websites!
Like us on Facebook – Follow us on Twitter

Reply From: Rick

Hi Kostas
Thanku u for the reply, the duplicate element this is the case indeed as you can see in the code below

<!-- ******** END ALLWEBMENUS CODE FOR menu ******** -->
<div id="wrapper">
  <div id="mainbanner">
    <div class="clr"></div>
  </div>
    <div id="publicmenu">
    <div id="publicmenu"></div>
  </div>

The problem is in the module manager in Joomla I have to place a dummy module in the menu position to replace the Joomla built in menu. because if I dont display or publish the joomla menu my allwebmenu will also not display, and if I publish the joomla built in menu then I have both menus showing on top of each other. So a dummy module in position-01 seems to be a work around
Thank u for pointing it out
Regards Rick

 

Tags: , , , , , , , , , , , , , , , , ,