Knowledge Base support case for AllWebMenus, abstracted and stripped of all user’s private info.


Initial Email From:
Mick
Initial Email Subject: Drupal 7 site Addin menu display
Support Case Month: April 2012

I've tried to follow your instructions for creating an AllWebMenus menu in Drupal 7.

After importing the main menu from Drupal, I styled a beautiful AWmenu. This I compiled and, using the linko-7 Drupal module, uploaded. I set the bocks to show menu1 in the menu area - nothing appeared. So as not to leave the site without a menu I also placed the Superfish menu block in the menu block and that appears.

Re the html.tpl.php modification, my Drupal Respond theme <http://drupal.org/project/respond> doesn't have a  html.tpl.php file. But the Respond theme is a subtheme of the Omega theme <http://drupal.org/project/omega>, which does have that file.

The body tag starts as <body<?php print $attributes;?>> and I added <?php if (function_exists('AWM_Linking_Code')) AWM_Linking_Code(); ?> after that, but still nothing.

Any suggestions please on how I get the AWmenu to appear in Drupal 7?

Thanks and Regards

Mick

Reply From: Likno Customer Support

Dear Mick,

I believe the problem is that you renamed the zip.

The zip should already have the correct name. To achieve this, the “compiled menu name” in the application must match the online menu name.

In your case, you must either change the online menu name from “menu1” to “menu”:

menu name

or change the compiled menu name from “menu” to “menu1”.

compiled menu name

Regards,
Kostas
Likno Customer Support
www.likno.com
Create any type of javascript menu (CSS menu, drop-down menu, sliding menu), button, html tree, modal window, tooltip, accordion, tab, scroller, jQuery slider or design for your websites!
Like us on Facebook – Follow us on Twitter

 

Tags: , , , , , , , , , , ,

 

Knowledge Base support case for AllWebMenus, abstracted and stripped of all user’s private info.


Initial Email From:
Keld
Initial Email Subject: I have two menus
Support Case Month: July 2012

Dear support

I use joomla 2.5. and are excited over the possibilities of the AllWebMenus. This is my second webpage and i am a absolute beginner in the field. I use a lot of time to fool around - but i am determined to be better at the job.

I do have one problem, that seem difficult for me to solve and I hope that you will be able to help me with that.

I am a registered user. I have downloaded the latest AllWebMenus PRO var 5.3. and also the newest software AllWebMenus joomla menu component ver 1.1.15. I have generated the menu structure code from the webpage to use in the desktop program. I have compiled the structure - and uploaded everything to my webpage - but now I got two menus - the old joomla menu structure behind the new. I do not want two menus on top of each other.

I have tried a lot of things for a long time now and I am sure that there is a small thing, that I have done wrong. I hope you can help we with that please.

I am looking forward to hear from you.

Reply From: Likno Customer Support

Hello,

The two menus are not really related. If you want to remove the original Joomla menu, you have to do this from within the Joomla admin. This will not affect the AllWebMenus menu.

Regards,
Kostas
Likno Customer Support
www.likno.com
Create any type of javascript menu (CSS menu, drop-down menu, sliding menu), button, html tree, modal window, tooltip, accordion, tab, scroller, jQuery slider or design for your websites!
Like us on Facebook – Follow us on Twitter

Reply From: Keld

The menu is not showing in Explorer but is ok in chrome and firefox. What can I do to make it work. The site is www.trolleogkunze.dk

Regards
Keld

Reply From: Likno Customer Support

Dear Keld,

I just visited your site, but I did not see any menu there at all. There is no Likno code in the URL you sent.

Did you remove the menu in the meantime?

Regards,
Kostas
Likno Customer Support
www.likno.com
Create any type of javascript menu (CSS menu, drop-down menu, sliding menu), button, html tree, modal window, tooltip, accordion, tab, scroller, jQuery slider or design for your websites!
Like us on Facebook – Follow us on Twitter

Reply From: Keld

Dear Kostas

The menu should be appearing when you push the second menu item in the horizontal menu line - saying: "Vi tilbyder".

It should be to the left as usual vertical menus is - and you should be able to se it in Chrome and Firefox - but not in Explorer.

In fact I think the menu-program is rather fantastic and i am happy about it. So I would like it to work in IE also.

Would you take another look at my page and maybe give me some advice, please - as I am keen to learn - and there is so much to learn.

Regards

Keld :)

Reply From: Likno Customer Support

Dear Keld,

I checked the new URL and indeed there is a menu there that shows in most browsers but not IE.

The problem is with the Positioning element. Specifically you are not supposed to have a plain number as an element ID. This is considered "bad HTML" and although most browsers can cope with it, IE will just through an error and stop running any scripts on the page.

The ID can contain letters and numbers but must always start with a letter.

Regards,
Kostas
Likno Customer Support
www.likno.com
Create any type of javascript menu (CSS menu, drop-down menu, sliding menu), button, html tree, modal window, tooltip, accordion, tab, scroller, jQuery slider or design for your websites!
Like us on Facebook – Follow us on Twitter

Reply From: Keld

Dear Kostas

Thank you for the support.

I understand the problem and have been searching intenstly trying to find out what to do next. As I am looking at the joomla side - all it says is the side ID number (which is 480). There are nothing else to see. I have also been reading the help manual - and i just dont get it. Im on the edge of giving up. Do you have any ideas about what I should do now, then kindly please let me know. I will be very thankfull.

Regards

Keld :)

Reply From: Likno Customer Support

Dear Keld,

So you are not able to change this ID? Was this automatically generated by Joomla?

Then just try using the parent DIV, with class "module_content":

menu relative to an element

Regards,
Kostas
Likno Customer Support
www.likno.com
Create any type of javascript menu (CSS menu, drop-down menu, sliding menu), button, html tree, modal window, tooltip, accordion, tab, scroller, jQuery slider or design for your websites!
Like us on Facebook – Follow us on Twitter

Reply From: Keld

Dear Kostas,

Yes that was all I got from Joomla – BUT your support did the job. Now the menu looks fine in Explorer.

I thank you so much for being helpfull.

Best regards

Keld  Smile

 

Tags: , , , , , , , , , , , , , , , , , , , , , ,

 

Knowledge Base support case for AllWebMenus, abstracted and stripped of all user’s private info.


Initial Email From:
Andrea
Initial Email Subject: menu does not show up
Support Case Month: September 2012

Hello,

I updated my menu today changing the navigation items. After uploading the zip file it does not show up anymore e.g. on this page http://www.simply-my-comfort.com/index.php/en/about-us/company

It seems like the below code for the new menu is not inserted into the html code, it is missing when I check it. When I upload the old menu again which I backed up I see below code and the menu shows up fine. I have upgraded to the latest version I was entitled too before updating the menu, I also upgraded the wordpress plugin and it is enable. The element id is also there. Please advise asap as the website is currently unusable with the navigation. Thank you!

<!-- ******** BEGIN ALLWEBMENUS CODE FOR czen_menu ******** -->
<script type="text/javascript">
var MenuLinkedBy="AllWebMenus [4]",awmMenuName="czen_menu",awmBN="866";
awmAltUrl="";
</script>
<script charset="UTF-8"
src="https://www.simply-my-comfort.com/czen_menu.js"
type="text/javascript">
</script>
<script type="text/javascript">
if (typeof(Menu)!="undefined") awmBuildMenu();
if (typeof(czen_menu)!="undefined") ProduceMenu(czen_menu);
</script>
<!-- ******** END ALLWEBMENUS CODE FOR czen_menu ******** -->

Related URL: http://www.simply-my-comfort.com/index.php/en/about-us/company

Reply From: Likno Customer Support

Hello,

This seems very weird! Are you sure you only added some menu items? Is it possible that you also changed the compiled menu name?

Can you send me the old and new zip so that I can compare them?

Regards,

Kostas

Likno Customer Support

www.likno.com

Powerful javascript menus (CSS menus/drop-down menus/sliding menus), web trees, buttons, tabs, modals, tooltips, accordions, scrollers, designs for your websites!

Reply From: Likno Customer Support

Dear Andrea,

I was not able to find the problem for sure, but I have a hunch that it is related to an issue I’ve seen in the past.

The new plugin tries has an extra “info.txt” file and it tries to copy a specific value (contained in that file) into the database. It is possible that it does not have access to read this file or write into the database, and hence the menu is not updated and does not work.

Do you have direct access to the database?  If so, I can give you instructions on what to look for. I will also forward this to our developers to see if they can work on a fix that would work around this issue.

Regards,

Kostas

Likno Customer Support

www.likno.com

Powerful javascript menus (CSS menus/drop-down menus/sliding menus), web trees, buttons, tabs, modals, tooltips, accordions, scrollers, designs for your websites!

Reply From: Andrea

Hello Kostas,

I manually inserted below code into the Joomla template index.php files for now so that the menu shows up and the website is usable.

<!-- ******** BEGIN ALLWEBMENUS CODE FOR czen_menu ******** -->

<script type="text/javascript">var MenuLinkedBy="AllWebMenus [4]",awmMenuName="czen_menu",awmBN="866";awmAltUrl="";

</script>

<script charset="UTF-8" src="https://www.simply-my-comfort.com/czen_menu.js" type="text/javascript">

</script>

<script type="text/javascript">

if (typeof(Menu)!="undefined") awmBuildMenu();

if (typeof(czen_menu)!="undefined") ProduceMenu(czen_menu);

</script>

<!-- ******** END ALLWEBMENUS CODE FOR czen_menu ******** -->

Please let me know if you find another solution so it will be working fine for the next update. Thank you for all your help!

Andrea

Reply From: Likno Customer Support

Dear Andrea,

This is a very good temporary solution until we issue a permanent fix for the problem.

However after checking your two menus again I believe this is a very simple issue caused due to a feature we added between the two versions.

Specifically with the new version you now have an extra module that allows you to define where you want your menu to appear! The default is set by Joomla to “No pages” hence you need an extra step to make your menu show. Please check under modules to find the module:

AllWebMenus  and Joomla plugin manager

Then select a position (doesn’t really matter as the AllWebMenus positioning will be used) and in the “Menu Assignment” make sure that you select “On all pages”:

assign AllWebMenus on all pages

Note: This is also shown at the bottom of the Joomla instructions page on our site (http://www.likno.com/addins/joomla-menu.html) but I guess it is natural for older users to not think of going back to the instructions. Having said this, in your opinion what would be the best way to inform our users of such changes in the future? I am asking this as we are always trying to find better ways to resolve such issues. Any feedback would be greatly appreciated.

Regards,

Kostas

Likno Customer Support

www.likno.com

Powerful javascript menus (CSS menus/drop-down menus/sliding menus), web trees, buttons, tabs, modals, tooltips, accordions, scrollers, designs for your websites!

Reply From: Andrea

Hello Kostas,

As mentioned in my previous email I got to work the menu after applying below. However when I just looked at the site in Internet Explorer 9, it is still not showing up: http://www.simply-my-comfort.com/index.php/en/about-us/company

Is it possible that there is an incompatibility with IE9?

Thank you!

Andrea

Reply From: Likno Customer Support

Dear Andrea,

It seems that you have two page elements with the same ID (the one you use for positioning):

two page elements with same ID

This is considered as invalid HTML and although most browsers will use the first occurrence IE will block both, hence hiding the menu.

Please make sure that the Positioning ID exists only once in your HTML.

Regards,

Kostas

Likno Customer Support

www.likno.com

Powerful javascript menus (CSS menus/drop-down menus/sliding menus), web trees, buttons, tabs, modals, tooltips, accordions, scrollers, designs for your websites!

Reply From: Andrea

Thank you for your help and looking into this.

In my template code I only used:

<div id=”navigation”>

     <jdoc:include type="modules" name="top" style="xhtml" />

</div>

However for the Joomla pages it seems like after compiling the menu for the live code another

<div id=”navigation”></div> was inserted.

So I changed the template code to only

<jdoc:include type="modules" name="top" style="xhtml" />

to avoid the doubling up and it seems to work.

Andrea

 

Tags: , , , , , , , , , , , , , , , , , , , , , , , , ,

 

Knowledge Base support case for AllWebMenus, abstracted and stripped of all user’s private info.


Initial Email From:
Brent
Initial Email Subject: Positioning Vertical Menus in Joomla
Support Case Month: August 2012

I am experiencing trouble placing my vertical AWM in any of the left hand positions in Joomla 2.5 in such a way that if another module is added to the left, it appears below the menu. When you respond back I will attach an image for you. I am using an Artisteer template.

Thanks in advance for the help.

Reply From: Likno Customer Support

Hello again,

Can you please send me a screenshot regarding this issue? Are things appearing under the menu? If so, then you need to check the following option in AllWebMenus:

menu type vertical position

Regards, 
Kostas
Likno Customer Support
www.likno.com
Create any type of javascript menu (CSS menu, drop-down menu, sliding menu), button, html tree, modal window, tooltip, accordion, tab, scroller, jQuery slider or design for your websites!
Like us on Facebook – Follow us on Twitter

Reply From: Brent

Hi Kostas,

You know sometimes in life you get those dull moments when something stares you in the face and you just don’t see it. This is one of those. Thanks for pointing it out to me. I now have four sites that I can update the menus accordingly.

Hope you enjoyed your vacation.

Warm Regards

Brent

 

Tags: , , , , , , , , , , ,

 

Knowledge Base support case for AllWebMenus, abstracted and stripped of all user’s private info.


Initial Email From:
Rick
Initial Email Subject: No Menu in IE9
Support Case Month: October 2012

Hallo Support

My menu shows in all browsers except in IE9

My setup is Latest Allwebmenus 5.3 Build #898 Joomla 2.5 and AllwebMenu's extension running of wamp local host.

All browser are up to date.
Firefox 15, Opera, Safari

I have uninstalled and re installed the joomla plugin a few times, recompiled the joomla zip also a few times but nothing.

I also use Template creator CK plugin for Joomla. Menu position is relative to element custom ID nav.

Its only IE9 that it wont show.

Help will be much appreciated here. And thanks for a grate program.

Regards

Rick

Reply From: Likno Customer Support

Dear Rick,

I am afraid I cannot be sure on what the problem is without actually seeing your page.

However my guess is that you are positioning your menu relative to an element and that you somehow ended up with duplicate IDs in your page. When this happens most browsers will just use the first element found, but IE will disregard all of them hence not showing the menu at all. Please check if your Positioning ID is duplicated in your page and remove any “extras” in order to fix the problem.

If this is not the problem, then please send me the URL so that I can check the page.

Regards,
Kostas
Likno Customer Support
www.likno.com
Create any type of javascript menu (CSS menu, drop-down menu, sliding menu), button, html tree, modal window, tooltip, accordion, tab, scroller, jQuery slider or design for your websites!
Like us on Facebook – Follow us on Twitter

Reply From: Rick

Hi Kostas
Thanku u for the reply, the duplicate element this is the case indeed as you can see in the code below

<!-- ******** END ALLWEBMENUS CODE FOR menu ******** -->
<div id="wrapper">
  <div id="mainbanner">
    <div class="clr"></div>
  </div>
    <div id="publicmenu">
    <div id="publicmenu"></div>
  </div>

The problem is in the module manager in Joomla I have to place a dummy module in the menu position to replace the Joomla built in menu. because if I dont display or publish the joomla menu my allwebmenu will also not display, and if I publish the joomla built in menu then I have both menus showing on top of each other. So a dummy module in position-01 seems to be a work around
Thank u for pointing it out
Regards Rick

 

Tags: , , , , , , , , , , , , , , , , ,

 


© 2009-2013 Likno Blog – Drop-Down Menus, Javascript Menus, CSS Menus, jQuery Scrollers/Sliders, Modal Windows