Knowledge Base support case for AllWebMenus, abstracted and stripped of all user’s private info.


Initial Email From:
Sabine 
Initial Email Subject: Problems with the position
Support Case Month: November 2013

Hello,

I’ve successfully compiled a menu from AllWebMenus.

Now I have problems to the right position for my menu in different browsers.

The Browser-specific Offsets don’t function. By testing the side in the different browsers, the menu is always on the same position. The correction for Offset x and y is not active.

Regards,
Sabine

Reply From: Likno Customer Support

Hello Sabine,

I see that you have positioned your menu relative to an element with id="awmAnchor-topmenu".

menu positioning settings

But in your page you don't have such an element. You get the menu to be displayed as it is CSS, but it only shows relative to your page flow.

In your page you have an element <div id="awmAnchor "> &nbsp; </div>

Please, change that to <div id="awmAnchor-topmenu"> &nbsp; </div>

Then, you need to change the offsets so that it displays in all browsers in the place you want it.

After, you make the changes in AllWebMenus, you need to re-compile your project and re-upload the produced files to your server.

Let me know if you need more information.

Thank you!

Kind Regards,  

Aggelos Tsakonas
www.likno.com
Powerful javascript menus (CSS menus/drop-down menus/sliding menus), web trees, buttons, tabs, modals, tooltips, accordions, scrollers, designs for your websites!

Reply From: Sabine

Hi,

Thanks a lot. It’s now very well.

Regards,
Sabine

Tags: , , , ,

 

There are 2 main positioning options:
       1. Automatically show Main Menu on page load
               1.1 Relative to Window
               1.2 Relative to an Element
               1.3 Relative to an Image
       2. Manually trigger Main Menu or any Group on user action
               2.1 On Mouse Over event
               2.2 On Mouse Click event

Below you can watch a video presentation in which we describe how you can position a JavaScript/CSS menu in AllWebMenus Pro.

Tags: , , , , ,

 

Knowledge Base support case for AllWebMenus Pro, abstracted and stripped of all user’s private info.


Initial Email From:
Michelle
Initial Email Subject:  menu positioning different in Internet Explorer vs Firefox
Support Case Month: November 2013

I have my menu relative to window set for Firefox. In Internet Explorer, it's totally off the page of my site. How do I fix this without screwing it up for the other browser?
Thank you!

Reply From: Likno Customer Support

Hello,

I would recommend you to position your menu relative to an element or an image.

You have that code in your page:

image code in page

You could add an ID in your <td> (you could give it the default name that AllWebMenus gives you in positioning settings) or you could position it relative to an image, so your setting would look like:

menu relative to an image

Let me know if you need more information.

Thank you!

Kind Regards, 
Aggelos Tsakonas
www.likno.com
Powerful javascript menus (CSS menus/drop-down menus/sliding menus), web trees, buttons, tabs, modals, tooltips, accordions, scrollers, designs for your websites!

Reply From: Michelle

Thank You,
Michelle 

Tags: , , , , , , , ,

 

Knowledge Base support case for AllWebMenus, abstracted and stripped of all user’s private info.


Initial Email From:
Klaus
Initial Email Subject: Menu not showing in ANY browser
Support Case Month: August 2013

I wrote a bit ago that the menu was not showing in IE7.
Since I re-compiled using the new Linkno build #916 the menu does not show in any browser. 

Please look at the code on either the home page or the {URL REMOVED} page, as all others now have wrong code due to an error I made. The code on the 2 pages noted above appears correct. No changes were made in the menu other than re-compiling, no position changes, etc. My client is very angry with me about this.

Thank you

Reply From: Likno Customer Support

Hello,

My first guess is that you don't use the correct positioning in your settings. As i see in your page you have a div with and ID = "awmAnchor-tristarMCTop".

Please, make sure that in your AllWebMenus positioning settings you have set that element as your positioning element. (see screenshot attached) Then, re-compile your menu project and re-upload the produced files. If the above is not the case, please export your menu project (File ->  Export Project -> To Zip File) so i can have a better look on this problem.

Thank you!

Kind Regards, 
Aggelos Tsakonas
www.likno.com
Powerful javascript menus (CSS menus/drop-down menus/sliding menus), web trees, buttons, tabs, modals, tooltips, accordions, scrollers, designs for your websites!

Reply From: Klaus

Hello Aggelos,

That (the custom positioning) fixed it perfectly! And, because of the new release, it works perfectly now in IE7 as well.

THANK YOU! GREAT support 🙂

Klaus

Tags: , , , , ,

 

Knowledge Base support case for AllWebMenus Pro, abstracted and stripped of all user’s private info.


Initial Email From:
Peter
Initial Email Subject: Dreamweaver templates
Support Case Month: July 2013

Hi everybody

My name is Peter, also known as Dr. Z. I'm in the process of updating the visual appearance of our website.

A website was developed in Dreamweaver with Firefox in 1998 through 2000.
I've not been able to use the AllWebMenus with the Dreamweaver templates which our website is based on.
As you can see, currently I'm positioning the menu below the main image on the page.

That works quite nicely as you can see here on the test server {URL REMOVED}
the currently functioning website is {URL REMOVED}

The only problem is: different folders have different main images with different image names.

Is there a solution to this?
In other words can I position the menu on different pages relative to different images?

If the answer is yes, please tell me how to do this.
I've tried to position the menu relative to a page element in the Dreamweaver template.

Every time I do that, most of the template somehow disappears.

This may have to do with the fact that there  are no body tags  in the template.
Please respond to me soon... I hope this is solvable.

Reply From: Likno Customer Support

Hello Peter,

As I see in your new page the whole page is based in this table:

<table width="800" cellspacing="0" cellpadding="0" bordercolor="#000000" 
border="0" bgcolor="#FFFFFF" align="center">

My recommendation would be to position your menu based to this, which I guess is the same in all of your pages. Give this table an ID and set the proper menu positioning in AllWebMenus.

For example:  In menu positioning select the default ID and then set the offsets of your desire to fit your design and then your code should have this ID

<table id="awmAnchor-menu" width="800" cellspacing="0" cellpadding="0" 
bordercolor="#000000" border="0" bgcolor="#FFFFFF"  align="center">

menu positioning

Or you could do that with another element that will be in all of your pages.

Let me know if you need more information.

Thank you!

Kind Regards, 
Aris
www.likno.com
Powerful javascript menus (CSS menus/drop-down menus/sliding menus), web trees, buttons, tabs, modals, tooltips, accordions, scrollers, designs for your websites!

Reply From: Peter

Hi Aggelos,

Thanks for your help.

So basically I followed your advice and inserted a table with the menu ID in the Dreamweaver template.
It works well.

Thanks very much.

My best,
Peter

Tags: , , , , , , , , ,

 


© 2009-2013 Likno Blog – Drop-Down Menus, Javascript Menus, CSS Menus, jQuery Scrollers/Sliders, Modal Windows