Knowledge Base support case for AllWebMenus,  abstracted and stripped of all user’s private info.


Initial Email From:
Eric
Initial Email Subject: Menu not displaying in IE8
Support Case Month: January 2013

I've generated a menu using the latest version and update of AllWebMenus in the website {URL REMOVED}.  However, the menu does not seem to display in IE8.  All I see is a white, blank space at the top of the page, just above the collage of photos.
There is also a little "Error on page" icon at the bottom left, that when clicked, says "Object doesn't support this property or method" and refers to Line 10 in the awmlib1.js file.
It seems to work fine in all other browsers, however, there seems to be a few people who are friends with the owner of the website who are using IE8 and can't see the menu.  Any ideas how to resolve this issue?
Thank you

Reply From: Likno Customer Support

Hello,

The problem is caused by your Positioning Code. Specifically it seems that you have given the same id (“awmAnchor-menu”) to two elements in your page.

This is considered invalid HTML as the id of each HTML element must be unique. Most browsers correct this by keeping only the first instance, however IE prefers to just ignore all instances, hence the menu does not find the Positioning Element to attach to.

Please correct this by removing the duplicate ID.

Best Regards,
Kostas
Likno Customer Support
www.likno.com
Create any type of javascript menu (CSS menu, drop-down menu, sliding menu), button, html tree, modal window, tooltip, accordion, tab, scroller, jQuery slider or design for your websites!
Like us on Facebook – Follow us on Twitter

Reply From: Eric

Excellent.   Thank you for your help.
Eric

Tags: , , , , , , , , , , , ,